WPMU 2.6 to 2.8 upgrade errors

By | August 11, 2009

I am the Webmaster of Gujarati Sahitya Sarita Website. From past so many days I wanted to update this site but couldn’t get enough time to get it done. Finally I dared to upgrade this site. This site was using old codebase wpmu 2.6. Upgrade from 2.6 to 2.7 was easy. I had to do it manually. It worked fine but then I auto upgraded to 2.8.

Now when I tried to login, it gave me weird error “You do not have sufficient permissions to access this page” even though I tried to use “admin” username.  I searched a lot but not found enough information. I also tried to debug the code but all in vein. Finally I directly looked into table “wp_usermeta” for userid = 1, meta_key=”wp_1_capabilities”. I found that it contains value “Administrator” instead of “administrator”. I changed it to lowercase and I was able to login.

Once I logged in, I cannot view “Site Admin” menu which is a must for managing overall functionality of the blog. I tried to search it but could not find anything. I looked into table “wp_sitemeta” for Site_id = 1 and meta_key = “site_admins”. I found extra “\” (backslash) into the value. I removed it and it worked fine.

Also I lost all my sitewide settings so make sure you apply those settings again.

Vishal Monpara is a full stack Solution Developer/Architect with 12 years of experience primarily using Microsoft stack. He is currently working in Retail industry and moving 1’s and 0’s from geographically dispersed hard disks to geographically dispersed user’s mind leveraging geographically dispersed team members.

One thought on “WPMU 2.6 to 2.8 upgrade errors

  1. rina

    Thanks for the update. I’m about to update one of my sites, this would surely help 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *